h1

Error: Missing Dependency: perl(Convert::ASN1) is needed by package samba

April 1, 2010

Error
root@server276 [~]# yum -y install samba samba-client samba-common
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: hpc.arc.georgetown.edu
* base: mirror.trouble-free.net
* extras: ftp.lug.udel.edu
* rpmforge: apt.sw.be
* updates: mirror.clarkson.edu
Excluding Packages in global exclude list
Finished
Setting up Install Process
Resolving Dependencies
–> Running transaction check
—> Package samba.x86_64 0:3.0.33-3.15.el5_4.1 set to be updated
–> Processing Dependency: perl(Convert::ASN1) for package: samba
—> Package samba-client.x86_64 0:3.0.33-3.15.el5_4.1 set to be updated
—> Package samba-common.i386 0:3.0.33-3.15.el5_4.1 set to be updated
—> Package samba-common.x86_64 0:3.0.33-3.15.el5_4.1 set to be updated
–> Finished Dependency Resolution
samba-3.0.33-3.15.el5_4.1.x86_64 from updates has depsolving problems
–> Missing Dependency: perl(Convert::ASN1) is needed by package samba-3.0.33-3.15.el5_4.1.x86_64 (updates)
Error: Missing Dependency: perl(Convert::ASN1) is needed by package samba-3.0.33-3.15.el5_4.1.x86_64 (updates)
You could try using –skip-broken to work around the problem
You could try running: package-cleanup –problems
package-cleanup –dupes
rpm -Va –nofiles –nodigest
The program package-cleanup is found in the yum-utils package.

Soln

root@server276 [~]# wget http://dag.wieers.com/rpm/packages/perl-Convert-ASN1/perl-Convert-ASN1-0.21-2.el5.rf.noarch.rpm
root@server276 [~]# rpm -Uvh perl-Convert-ASN1-0.21-2.el5.rf.noarch.rpm
Preparing… ########################################### [100%]
1:perl-Convert-ASN1 ########################################### [100%]
root@server276 [~]# yum -y install samba samba-client samba-common
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: hpc.arc.georgetown.edu
* base: mirror.trouble-free.net
* extras: ftp.lug.udel.edu
* rpmforge: apt.sw.be
* updates: mirror.clarkson.edu
Excluding Packages in global exclude list
Finished
Setting up Install Process
Resolving Dependencies
–> Running transaction check
—> Package samba.x86_64 0:3.0.33-3.15.el5_4.1 set to be updated
—> Package samba-client.x86_64 0:3.0.33-3.15.el5_4.1 set to be updated
—> Package samba-common.i386 0:3.0.33-3.15.el5_4.1 set to be updated
—> Package samba-common.x86_64 0:3.0.33-3.15.el5_4.1 set to be updated
–> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================================================
Package Arch Version Repository Size
==============================================================================================================================================================
Installing:
samba x86_64 3.0.33-3.15.el5_4.1 updates 16 M
samba-client x86_64 3.0.33-3.15.el5_4.1 updates 5.7 M
samba-common i386 3.0.33-3.15.el5_4.1 updates 8.7 M
samba-common x86_64 3.0.33-3.15.el5_4.1 updates 8.8 M

Transaction Summary
==============================================================================================================================================================
Install 4 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 40 M
Downloading Packages:
(1/4): samba-client-3.0.33-3.15.el5_4.1.x86_64.rpm | 5.7 MB 00:03
(2/4): samba-common-3.0.33-3.15.el5_4.1.i386.rpm | 8.7 MB 00:03
(3/4): samba-common-3.0.33-3.15.el5_4.1.x86_64.rpm | 8.8 MB 00:02
(4/4): samba-3.0.33-3.15.el5_4.1.x86_64.rpm | 16 MB 00:04
————————————————————————————————————————————————————–
Total 2.7 MB/s | 40 MB 00:14
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : samba-common 1/4
Installing : samba-common 2/4
Installing : samba-client 3/4
Installing : samba 4/4

Installed:
samba.x86_64 0:3.0.33-3.15.el5_4.1 samba-client.x86_64 0:3.0.33-3.15.el5_4.1 samba-common.i386 0:3.0.33-3.15.el5_4.1
samba-common.x86_64 0:3.0.33-3.15.el5_4.1

Complete!
root@server276 [~]#

3 comments

  1. Thanks for this. I had the same issue (Missing … the ASN1 stuff). This fixed it for me.


  2. You da man!


  3. Yes!! great.
    It worked for me
    thanks



Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: